I am trying to automate mobile web using ios-driver. The browser does not even though the launches.

The configuration as shown on terminal by the command java -jar ios-server-standalone-0.6.6-SNAPSHOT.jar -newSessionTimeoutSec 40 -port 5555 is:

Running on: Mac OS X 10.10 (x86_64)
Using java: 1.8.0_45
Using Xcode install: /Applications/Xcode.
Using instruments: version:6.3.2, build: 57082
Using iOS version 8.3
iOS >= 6.0. Safari and hybrid apps are supported.
Applications :
CFBundleName=Safari,CFBundleVersion=600.1.4,/Applications/Xcode./Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator8.3.sdk/Applications/MobileSafari.

The Java code I used is as follows:

DesiredCapabilities caps = IOSCapabilities.("Safari");
caps.setCapability(IOSCapabilities.SIMULATOR, true);
RemoteWebDriver driver = new RemoteWebDriver(new URL("http://localhost:5555/wd/hub"), caps);
driver.get("http://www.google.com/");

The following lines are displayed on terminal:

59:05:611 WARNING InstrumentsCommandLine.start instruments crashed (40 SEC)
59:06:040 WARNING NewSessionNHandler.safeStart Instruments failed to start in the allocated time ( 40sec):Didn't get the capability back.Most likely, instruments crashed at startup.
59:06:476 WARNING NewSessionNHandler.safeStart app has crashed at startup :normal
59:06:482 INFO IOSServerManager.findAllMatchingApplications Safari application requested for SDK version: 8.3

Any help from anyone would be appreciated.



Source link https://sqa.stackexchange.com/questions/13558/-to-open-safari-app-on-iphone-simulator-while-running---using

LEAVE A REPLY

Please enter your comment!
Please enter your name here