I am getting the below while invoking my suite:

12:01:56,498 ERROR [] An error occurred [com.eviware..plugins.auto.factories.AutoDiscoveryMethodFactory], see error log for details
java.lang.ClassNotFoundException: com.eviware..plugins.auto.factories.AutoDiscoveryMethodFactory
    at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:190)
    at com.eviware..plugins.LoaderBase.loadAutoFactories(LoaderBase.java:112)
    at com.eviware..plugins.LoaderBase.loadFactories(LoaderBase.java:80)
    at com.eviware..plugins.PluginLoader.loadPluginFactories(PluginLoader.java:141)
    at com.eviware..plugins.PluginLoader.loadPlugin(PluginLoader.java:104)
    at com.eviware..plugins.PluginLoader.loadPlugin(PluginLoader.java:54)
    at com.eviware..plugins.PluginManager.doInstallPlugin(PluginManager.java:141)
    at com.eviware..plugins.PluginManager.access$600(PluginManager.java:43)
    at com.eviware..plugins.PluginManager$LoadPluginsTask.computeSequentially(PluginManager.java:420)
    at com.eviware..plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:377)
    at com.eviware..plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:382)
    at com.eviware..plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:365)
    at java.util.concurrent.RecursiveTask.exec(RecursiveTask.java:93)
    at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:334)
    at java.util.concurrent.ForkJoinWorkerThread.execTask(ForkJoinWorkerThread.java:604)
    at java.util.concurrent.ForkJoinPool.scan(ForkJoinPool.java:784)
    at java.util.concurrent.ForkJoinPool.work(ForkJoinPool.java:646)
    at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:398)

Although the tests run fine. But these errors do come before invoking the test suite. What could be the possible reason?



Source link https://sqa.stackexchange.com/questions/26502/error-while--test--in-soapui-from-

LEAVE A REPLY

Please enter your comment!
Please enter your name here